Results 1 to 8 of 8

Thread: Question about wall recharger

  1. #1

    Default Question about wall recharger

    Hey guys,

    I'm using a "3.7V 1A Li-ion smart charger with 2.1mm plug", I noticed that the light started red, but when I plug it in to my saber, it soon turned green. My saber DOES need to be recharged, so the charger shouldn't have a green light. But I noticed that when I removed the plug from the saber, the light remained green. When I unplug it from the wall and plug it back in, the recharger goes from red to green (even when not plugged into my saber). The only thing that I can think of is that the green light means it's recharging and the red light means it's fully recharged, but that's not what the item description says, unless the manufacture screwed up the LED wiring? I thought I'd seek some sage advice from the Pro's before I plug my saber in and let it sit for a few hours.

    Thank in advance for any help... Stephen =]

  2. #2
    Owner of the Custom Saber shop Strydur's Avatar
    Join Date
    Oct 2005
    Location
    USA
    Posts
    3,486

    Default

    The chargers are supposed to go red then green when plugged into the wall with no battery plugged in.

    Also what do you mean by your saber does need to be charged.. what are you using to gauge that?
    Tim
    The Custom Saber Shop

  3. #3

    Default

    Quote Originally Posted by Strydur View Post
    The chargers are supposed to go red then green when plugged into the wall with no battery plugged in.

    Also what do you mean by your saber does need to be charged.. what are you using to gauge that?

    Hey Tim...

    There's no power when the kill plug is pulled, no sound, LED in the 16mm on/off doesn't light up, won't turn on when I push the switch. It's been a while since it was charged, so I assumed that it needs to be charged back up. That's why I'm confused when I plug in the charger that it turns green.

    Thank you for the quick response.

  4. #4
    Owner of the Custom Saber shop Strydur's Avatar
    Join Date
    Oct 2005
    Location
    USA
    Posts
    3,486

    Default

    Have you charged it before with this charger?
    Tim
    The Custom Saber Shop

  5. #5

    Default

    Quote Originally Posted by Strydur View Post
    Have you charged it before with this charger?
    This is the first time with THIS recharger. After my last message, I plugged the saber into the wall. The light was green, but when I turned it to set it down, the LED on the recharger started blinking red. It's been plugged in for a few hours, but doesn't seem to be charging. I just checked it a few minutes ago and still nothing (won't turn on). Think it could be the internal wiring??

    Thanks =]

  6. #6

    Default

    The simplest wiring issue is swapping the ground wires on the charge port.

  7. #7

    Default

    Yep, my thoughts as well, probably swapped the negative wires of the board and battery at the recharge port.

  8. #8
    Owner of the Custom Saber shop Strydur's Avatar
    Join Date
    Oct 2005
    Location
    USA
    Posts
    3,486

    Default

    Flashing red means something is wrong. Also unless it sat for months it would not be completely dead as you described. Not saying it cant be the charger but it does sound like something else is wrong.
    Tim
    The Custom Saber Shop

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •