Results 1 to 5 of 5

Thread: Neopixel build issue with CFX. Help please!

  1. #1

    Default Neopixel build issue with CFX. Help please!

    Hi everybody, so this is my first time building a proper lightsaber and wanted to take on this project from scratch. I of course chose to go with a Neopixel build with a Crystal Focus X board. I even went as far as building my own hilt from scratch by designing and 3d printing my own custom parts.

    So, I built the blade by using the parts from the shop. Used 2 sk6812 144 pixel strips with the pre-soldered pcb and 7 pin set (which also came with the 330ohm resistor installed). Followed all the instructions from the video available in the shop, everything had come out great. Then I did the board, used a Crystal Focus X mk2, wired it up using 22 and 24 gauge wires. I also used quick disconnect plugs for both the main switch and aux switch (momentary switches) and then I used another quick disconnect for the wires going to the hilt side pcb. I am using a 3.7v sony 18650 15a pcb protected battery I got from the shop as well.

    I put everything together, turned it on but nothing happened with the blade. There was sound and everything, the switch lit up as well but no light... so I remember reading in the manual I was supposed to change in the config the amount of pixels I was going to be using so I changed it to 124 since that was the number pixels in the blade (times 2 since I used 2 strips) so from what I understand, I need to put 124, not 248, correct? Anyways, turned it on again and everything worked, blade was working but I noticed the pixels were flickering and didn't look like all were a steady same color. Flashes and deflection effects worked as well, everything worked except it looked a little weird so stupid me started messing with it, and I think this was my biggest mistake, I moved the blade a little and even twisted it while connected and turned on. In one of the twists, all the lights came on steady (no more flickering) but as soon as I let go, the blade turned off. The blade wasn't secured into place and was just in position to have contact with the pins but they weren't even pushed in when this happened since it was just sitting in the table while I just tested the setup.

    Since then, all the sounds and switches work, I can change fonts and everything, all works except the blade lighting up.

    These are all the tests I've done so far to try to figure out what's wrong. I checked continuity on all the wiring and all is good. Checked for any loose connections and nothing seemed to be wrong. Then I checked power going to the pcb and the positives have ~3.62v when I test with one of the led negatives, the ones coming from l1 and l2 on the board but when I test the positive with the negatives coming from l3 and l4 I don't get 3.62v I get random numbers... so I re-ran all the neg wires going to the hilt side pcb straight from the main board ground. It still didn't power on the blade. I took the blade apart, made sure all the connections were good and indeed everything looks good and there is continuity... so I thought maybe I fried the led strips somehow so I built a tiny little strip with about 20 pixels from the leftovers I had when I cut the strips for the size of the blade. Mocked it up to test and this doesn't turn on either... wth!!! So I charged the battery and nothing, used another battery and nothing, I formatted the sd card and reloaded it with a backup of the original and nothing (I changed the number of LEDs to 124 on the new formatted card) only thing I don't know how to properly test is the data line other than it has continuity... Is there a way to actually test the led strips and turn them on aside from using the soundboard?

    I'm not sure what else I can do here or what am I doing wrong? Any help would be greatly appreciated and I apologize in advance for the long post lol .... I can post some pictures or videos later Thanks

  2. #2


    If you twisted blade hard in socket, you could have bent the pins on the hilt side connector, or jammed the data pin in where it won't make contact with the blade target. But now you're saying the board won't boot? If so, check your positive and negative hiltside connector pins to see if you bent and/or shorted any of them. If you shorted them, there is a chance you could have damaged the CFX itself.

    "Let the past die."

  3. #3


    I checked everything already, the pins were fine, they didn't bend since it wasn't fully plugged in the blade seems like the problem is at the ls1 data port, I most likely shorted it when I twisted the blade but I couldn't find any burn spots or anything like that. After doing several tests, it came down to this being the only thing not working. I rewired it using the ls2 aux data port and it's working now but I wish I could somehow fix the ls1 since using the ls2 means it doesn't have the blaster effects.

  4. #4


    Can you upload some pictures please?

  5. #5


    I don't know if this will help you (I'm super new to this too), but my ledstrip blade was alternating pastel bands instead of a solid color. It turns out I needed to modify the config file to know that I had a RGBW strip (it thought it was RGB)... To change that parameter, I set the 4th digit in the "strippower" parameter from 0 to 1.

    I also had 118 LEDs in the blade (and crystal chamber), but for some reason, I had to change the "ledstrip" number to 153... not quite double. Have no idea why. Maybe play around with those numbers?


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts