Results 1 to 3 of 3

Thread: Still not getting anywhere with my saber build.

  1. #1

    Default Still not getting anywhere with my saber build.

    Hey guys. Still working on my first board.

    Green Rebel Star LED with Heatsink
    28mm speaker
    .47 OHM resistor. I believe I have attached it correctly
    Momentary switch
    had to order another recharge port as I fried mine the second time on the second sabercore board.
    3.7 lithium ion battery

    Any suggestions on what to maybe attach first and test? How to test? I don't get sound or any light from the LED. I get nothing. Will I need the recharge port in order to charge the battery? Probably didn't come fully charged. Really could use some help. Frustrated, but have watched videos and it's probably something with my soldering (lack of skills) or not using heatshrink at the board so there is a short? Just looking for a step by troubleshoot. Hopefully the pics are useful.
    Attached Images Attached Images

  2. #2


    Hey boss, shoot me a text if you're still up and let's see if we can troubleshoot a bit.

  3. #3


    I might not be to much help as I’ve never wired that board before so when I look at your wiring I can’t really tell what’s going on. When I get into spots like this I usually will pull out a multi meter so I can trace the power and see if it’s going through or not. I can usually solve most problems by doing this. Also I would look at the manual and follow the diagram and make sure everything is in it’s correct spot. Also make sure your recharge port is wired correctly, you scare me when you say you fried one. Memorize the wiring on that sucker so next time you don’t even need to think about it. Sorry I’m not more help, but the more you do this stuff the more you learn.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts