Page 1 of 8 1 2 3 ... LastLast
Results 1 to 10 of 79

Thread: Neopixels no longer work...

  1. #1

    Unhappy Neopixels no longer work...

    This is my first build and I thought I had it all done, but now I have an issue. I have a CFX board, 144x2 neopixels with the Panasonic 7.4v lithium-ion battery sold here on TCSS. Everything was working fine until I edited the Config file to put a value on the qon and qoff parameters to try to increase the speed that my blade lit and powered off as it was slow. The config file that was sent with the board did not have these values so I added them. After that about 10 of the leds on 1 side of the board lit. I tried removing the settings, restoring from a backup and even downloading a whole new set, formatting the card and copying back the whole set of fonts putting only the 144 on the ledstrip parameter and now I get absolutely no lights. I have tried a firmware update as well in hopes that it might help. I checked the voltage on both sides and at the bottom and top of the strip I get 7.4v on both sides so it does not appear to be a connection problem. I am at a loss as to what to look for next... Any suggestions would be helpful. Thanks!

  2. #2


    The CFX is normally set to run with a 3.7V battery. If you used any of the 7.4V from the store, they don’t put out anywhere near enough amperage to run 2 Neopixel strips.
    All n00bs READ these first (PLEASE)!!!:
    1. Forum Guidelines
    2. FJK’s “Down and Dirty” guide to Ohm’s Law

    "Yeah, yeah, I've heard it all before... you want blindingly bright, super loud, running 1138 blinkies off of the cheapest sound card you can find AND you want all of it to run on a battery the size of a dime, and run for a very, VERY long time. That one cracks me up every time..."
    My email:

  3. #3


    Then why did they work I initially for a couple of days? If they never worked, I could accept that answer... But the fact that they worked tells me otherwise...

  4. #4


    hey have you RTFM for the CFX? The board is not necessarily limited to the 3.7v; p.g. 22 of the CFX manual says the max voltage the board will accept is 9v so the board should be fine.

    This is the pack you used correct CFX manual p.g. 121 (talking about battery requirements) suggest a fully driven RGB draws at least 5000mAh; and 10,000mAh with White flash on clash. These batteries are only 3400mAh.

    I'm no CFX expert; just trying to help with pertinent info from the manual.

    Stupid question (but I have to ask) have you tried re-charging the battery pack?

    - Steve

  5. #5


    Yes that is the battery I am using... I did read the manual, lol sounded like my electronics teacher from DeVry years ago...�� I understand that the battery seems underpowered, just still confused as to why it worked the first 20 times I turned it off and back on.. It was only when I changed the qon/qoff setting that it went sideways. I am charging it now and I have resoldered anything that seemed sketchy to make sure. Even replaced the wires on the neopixel strips and resoldered the pcb... I'll keep you posted...
    Last edited by; 03-01-2020 at 08:20 AM.

  6. #6


    Ok so after charging for a while, same result. Let's go with the theory of an underpowered battery, which one would you suggest? I am trying to find out the specs of this battery but I am having no luck. Is there any other way I can test the LEDs to make sure they still work?
    Last edited by; 03-01-2020 at 01:27 PM.

  7. #7



    This one from the store should be good. I thought I read somewhere online of someone using a 26650 "Big-Boy" too but that seems crazy overkill... I leave that for someone else to chime in on.

    The one you have now doesn't seem to have a max amperage rating listed in the store.

    I did find this thread discussing a similar issue someone else was having.

    Let us know how it all turns out.

  8. #8


    I'm gonna order the battery you suggested, but how can I test the led strips to make sure they are still good?

  9. #9


    I checked the voltage on both sides and at the bottom and top of the strip I get 7.4v on both sides so it does not appear to be a connection problem
    If you tested the strips and you still get the 7.4v on both sides then the strips are still good.

    how can I test the led strips to make sure they are still good?
    Do you have a bench test power supply? If you apply 5 volts @ 10amps it should light up. Barring that, I think the only way to properly test is wait until you have suitable battery... unfortunately.

    - Steve

  10. #10



    Thank you for all your help, I reallyappreciate it. Unfortunately I don't have a bench supply... I will have to wait until I get the new battery to test...

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts