Results 1 to 4 of 4

Thread: PRIZM V5 with RGB led, Rotating Crystal Chamber + led and two AV switches

  1. #1

    Default PRIZM V5 with RGB led, Rotating Crystal Chamber + led and two AV switches

    Hello all,

    I need help ASAP!

    Just recently got all the parts in for a build Iím doing with a prizm v5 board and wanted to wire up the rgb led for color mixing, as well as a rotating chamber with rgb led to match main blade. I also have a green and blue anti vandal switch (for activation and aux switches)...

    I had everything wired up, pulled the kill key and none of the leds worked and the rotation of the chamber started immediately when I pulled the kill key.

    Sounds and effects all worked just no led..
    Used Shameems video for basic prizm install for reference:

    I had the negatives to each main led wired to the L1,2,3 on the board
    Each rgb negative for the crystal led was conjoined with each led to match main blade
    Motor for chamber wired directly to main positive and negative to board
    Main switch led wired to main positive and negative to board
    Aux switch wired to an aux led pad to add a blink

    Chamber rotated as soon as plug was out, none of the leds turned on.
    Iím attempting to have rotation and chamber led begin with blade ignition and have chamber led match blade

    What do I need to change in my wiring and have what go where to get this to work?
    PLEASE HELP! Thank you

  2. #2
    Jedi Initiate hapki's Avatar
    Join Date
    May 2014
    Location
    United States
    Posts
    449
    Blog Entries
    19

    Default

    Re: "Main switch led wired to main positive and negative to board"

    The activation switch should be wired to the activation switch ("ACT") spot on the board. I'm guessing, but, perhaps the PRIZM isn't getting the signal to turn on the main LEDs. It requires an interrupted circuit, either normally on and clicked off or vice versa. You will also need to wire up a second momentary switch, the auxiliary switch.

    Also, do you have resistors on the negative wires between the PRIZM and the LEDs? If not, you may have fried the LEDS.

    Sorry I'm giving you info that you already know.

    HapKi

  3. #3

    Default

    Quote Originally Posted by hapki View Post
    The activation switch should be wired to the activation switch ("ACT") spot on the board.
    I'm no expert, but that's the switch post that needs to wire to the ACT spot on the board, not the LED. The Prizm manual has a section on wiring power-on LEDs so I'd suggest looking at that wire your AV switch LEDs according to those instructions. Where you wire to depends on if you want it on all the time (when the kill key is pulled), or to go off during deep sleep. Where you're using a kill key I'm guessing the on all the time option is fine.

    If you want the crystal chamber to only rotate when the blade is ignited, then I'm guessing you'd want to run it off the high-powered LED section, but I'll admit I have zero experience with whether this works, the pads can meet the power requirements, or what other things you might have to account for in that type of setup. This is pure speculation on my part, and based solely on the knowledge that those pads activate with blade ignition.

    I would also echo the comment about resistors and making sure you're using the appropriate values in each part of the circuit.

  4. #4

    Default

    Do you have a wiring diagram? Is your soldering good? No bridges? did you run individual positives off the LED, or did you common them up in the star? If you commoned them up in the star, or used a NECree...check that positive connection.

    The Prism 5.1 has been pretty bullet proof for me. I have put 3 of them in sabers, and have one on my bench that gets thrown in boxes and generally abused. I also have been using it for the last 2 months to bench test different diffusion techniques for neopixel blades. It still works perfectly fine.

    If you wired your CC Motor directly to power, it would turn as soon as you pull the kill key. If you want it to turn when the saber is on, yeah, it really needs to be run by either one of the accent pads (which you would have to program in the leds.txt in each font configuruation folder.) When you write that program in the leds.txt, you would just program one pad to remain on when the saber is running, and you can program another accent to blink for each font that isn't the motor, so that your motor LED pad won't be pushing power to it when the saber is in idle.

    This seems like a pretty advanced project here. Good luck!

    Tom

    "Let the past die."

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •