View Full Version : Crystal Focus 3.x problem

Matt Thorn
09-01-2009, 06:16 AM
I've never had any trouble with the Crystal Focus 3.x in my Qui Gon saber, until today. After recharging it (for the first time in quite a while), a strange thing happened. When I pull the kill-key, the saber makes its standard start-up sound. And when I push the switch, the saber fires up. And immediately fires down. Then immediately fires up again, and fires down again...endlessly.

I tried to reset the board by replacing the kill-key, then holding down the auxiliary button as I pulled the kill-key out again. (That is how to reset the board, isn't it?) Same problem.

Has anyone ever had anything like this happen? Does anyone know how to fix it?

Thanks in advance for any help.

Obi-Dar Ke-Gnomie
09-01-2009, 07:25 AM
Just a shot in the dark here, but sometimes my 4.0 acts funny if the SD card isn't sitting right. Try taking it out and putting it back in. Try it a few times to make sure the pads are making good contact.

Malaki Skywalker
09-01-2009, 07:47 AM
Might be worth checking the Configs. If its a latching switch you have make sure the "Switch=" in the config isn't on 2, visa versa.

Hope this helps

Kal El Rah
09-01-2009, 12:29 PM
Mine did that also, I tried the pull out and push in thing but I ended up just reformatting the sd and it worked fine afterwards, I seems that the sd card lost info.

09-02-2009, 11:46 AM
The other possibility is you have a ground somewhere, most likely on the momentary switch. Either that, or your momentary is broken (and most likely shorting/closing the switch). I had that happen with one of my CF's, which was quickly resolved :)

09-02-2009, 03:32 PM
Back in the DAY... when I had some v1.2 boards--I had this problem as well.

Ultimately I was never totally 100% sure of things... but I'm pretty sure it was a grounding issue.

Try removing the electronics entirely from the hilt, and test very thoroughly. If you cannot repeat the problem (with electronics isolated from hilt)... it's a good sign that it IS a grounding issue.

Why it may not have been happening before--is irrelevant: electronics can be finicky... and things can shift around after the things gets a ton of beatings. Ohhhhh SNAP. :)

09-02-2009, 09:14 PM
What he said :D