View Full Version : plecter sabercore V2.0 help!

07-14-2007, 08:30 AM
Hi, anyone who has bought the plecterlabs sabercore V2.0, I have wired it up according to what I've gathered is the right circuit (see wiring diagram I have drawn below).

I have a problem with it though. It is drawing too much current from the batteries, and tends to drain them in under 2 minutes, like I can see the pack's voltage going down and down every second when I apply the multimeter to the battery terminals.

I am using 4x AA NiMh 1.2v rechargables (energiser), and I have wired in the recharge port as a power switch (if you know the plecter board, it has 2 switches, one that boots it, and another one that activates the light and sound). It all works how it should, only eats the current up very fast like it should'nt.

can anoyone who has used the plecter boards give me any suggestion of why this might be happening, or generally even if you hav'nt and you know alot about electronics, and know the nature of current etc. give me some advice.



07-14-2007, 08:32 AM
by the way, just ignore the 2.8v I put there.

07-14-2007, 08:02 PM
When you say that it eats current "faster than it should"... what do you mean?

1. Does the entire board function? (light, sound, clash, etc.)

2. Did you set the current draw going to the LED correctly in the config.txt file?

3. Do you mean it sucks more current than "normal" when the board is "shut down", aka idle?

Erv's older board versions draw anywhere from 10ma to 20ma (yes, it's a lot) even when your switch is off. This is *mainly* because of the SD card, but also because of the accelerometer as well. And sure a few more things.

In his newer versions, the current draw is down to @6ma... although that is "technically" more than what a "normal" circuit would run.

Then again--the SD card is sucking down alot, and how is that Erv's fault (for the record)... :) At least it is programmable.

07-14-2007, 08:12 PM
I don't think he's blameing anyone, just wanting to know if it's wired right. :)

07-14-2007, 08:31 PM
I didn't mean it to sound that way--I'm simply saying, I myself learned from Erv that the reason for the "suck down" was the SD card. Makes sense when I think about it since it was made for a PC, and the programming for an SD is ****REEEAAALLLY**** involved, since it has to do with an operating system.

This is one of the main reasons Erv chose to go with the SD for the programmability portion of the Crystal Focus. Most other options (most--not all)... are rife with problems.

Unfortunately, the SD card has so much "gunk" to it, it sucks down a THRONG of current.

07-14-2007, 08:32 PM
good to know, hopefully I can get one sooner or later.

07-15-2007, 08:48 AM
Hi Novastar,
yes the board functions as it should, sound, light, boot sound etc. I hav'ent actually changed the settings in the .txt file, just left as default and hav'nt checked them. I might go back in and check them.

but how long does your saber go for? as long as an MRFX?

no id does'nt idle or take current when its shut down. and i've put the recharge plug setup there for a boot switch, and that works fine, does'nt draw current. what points would I check to see if the board is taking too much current from somewhere?

cheers -

07-15-2007, 01:49 PM
Ok, so if you're basically using the recharge port as a general power switch as well (I do that on my v1.2 boards), you should be good on not allowing the board to draw too much current from the batts...

Sooo... my guess is that you need to check to be certain that the config.txt file has the correct LEDcurrent value set for your particular LED.

Refer to Erv's site for the calculations to get it right for your LED.

I can tell you that mine is set to 60, which is basically 1.3A of current. Then again, my LEDs COULD take 1.5A (K2 green, also Lux III Red) but the v1.2 Crystal F don't support so much via a software limit.

07-16-2007, 06:43 AM
For the sake of testing the board, remove the recharge port from the circuit and just wire it up directly.

Also check for any solder bridges around the power pads, luxeon pads and any other place you have soldered wires on too.

A set of 2000ma batteries should last for a couple of hours at least and even though the board has a largish quiescient current its not that much. a 20ma draw will still take 200 hours to flatten a fully charged pack.

One other thing to check is that your batteries are actually being properly charged. I had a friend tell me his sabre only lasted 30 minutes. Turned out his automatic charger was cutting off way too soon and only partially charging the batteries.

07-16-2007, 06:26 PM
I didn't see a bit of what kind of "contact key" he's using. wiring the recharge port like that only does you any good if you have one.

Posting from South Dakota. It's 8:30 and the sun isn't set... lots of Amish. Weird place.

07-16-2007, 06:28 PM
south dakota, huh. where abouts? the boarder of SD is only about 3 or so hours away.

they make awsome furniture.

07-17-2007, 01:02 AM
I had reaver by email, sorry for the delay, could not post while I was in CE.
Check that you don't have any solder bridge close the the luxeon output, especially with this big green square flat resistor marked 0R15.
The board seems to function, sound etc, but : do you have the progressive effect, with the luxeon going progressively up and down during activation and retractation. If not, there might be a problem with the luxeon driver part of the board (can just be a wiring problem).
Check with a "normal" current, put ledcurrent parameter to 46 on the config file, or don't change anything if the SD card hasn't been modified yet (46 <=> 1A <=> default setting)

07-17-2007, 10:27 AM
I didn't see a bit of what kind of "contact key" he's using. wiring the recharge port like that only does you any good if you have one.That's a good point, X. For clarification, I use a plastic/nylon "kill key" that I slip into the recharge port when the saber is not in use.

This effectively cuts the battery leads from the board--as if the batteries were not soldered in at all. That will prevent current draw, although batteries WILL lose charge on their own over time.

Reaver--has any of this helped??

09-11-2007, 12:15 AM
Curious to know if Reaver ever solved/discovered this issue...

09-11-2007, 12:40 AM
what I use for my kill switch key is a machined piece of PVC. Basically it's the same measurements as a male charging plug but all in plastic.

09-18-2007, 02:53 AM
Hello! sorry I have been busy lately, had'nt checked back. Actually I found the problem. It was because a slag of solder had spat off the iron unseen, and bridged over one of the chip things on the board.

on closer inspection I wondered what it was, and now I found it. Nobody could have told me that was the problem without seeing it closely.

Actually now I'm having a bit of a problem with it beeping 3 times after the boot sound, then not playing the sound font. Erv has told me this is because somethings got confused with the naming/configuration of the sound fonts "bank1" etc, although I hav'nt changed that.

and he said if the auxillery switch is wired in, I can re-configure the sound banks through the saber's voice menu. So I'm in the process of doing that, so I'll let you know how it goes.

10-19-2007, 12:37 AM
How did it go, Reaver?

Also--hopefully you made sure to format the SD card and start all over whenever swapping/changing sounds or the config.txt file.

10-20-2007, 03:51 AM
Yes, it went well! I re-formatted the SD card everytime I change sounds now. But I'm having a beep problem with the aux switch. I assume getting into the menu is when the saber is off, but the recharge key is out, however, when I press aux switch it just gives me a beep and does'nt actually go into the voice menu.

anyhow, I'll try to reformat it yet again and see how it goes.
cheers novastar! Also I'm using your darkstar font quite often, awesome work with that soundfont! The deep hum resonates awesomely underground when I go exploring drains too!


Darth Morbius
10-22-2007, 11:15 PM
This sounds similar to my problem that I am having with my 2.63.

Upon initial boot, I get the normal boot sound, the saber works fine. I power the saber down (via general power switch), and remove the SD card to change parameters for idle, swing, and flicker.

After saving, I replace the card and reboot the saber. It works for a bout 20-30 minutes, then after powering off, and powering back on, I get nothing. No boot up sound, no soundbank selection menu, just a light hiss from the speaker.

At this point I have not been able to get the saber to boot up at all again.

I've triple checked the wiring, tested all the contacts with a meter, and everything seems to be in order, but it will not fire.

10-22-2007, 11:40 PM
Darth Morbius... did you try re-formatting the SD card and changing the settings? In general... Erv's setup requires a format before changing anything on the SD card.

Darth Morbius
10-22-2007, 11:53 PM
Yes, the card is reformatted each time I change parameters.

the problem being, the saber usually works for about 20-30 minutes, then on power down, it will not reboot.

It's done this twice now, and this time even reformatting the card doesn't help.

just a click from the speaker upon power-up, and a steady hiss...

This has perplexed me for 3 days now.

10-22-2007, 11:54 PM
What is your battery voltage and mAh rating... and the LED you are using?

Darth Morbius
10-23-2007, 12:12 AM
Im using 2 Protected Ultrafires Lc14500 3.6V @ 900mAh.

Actual reading from the pack is 7.75V @ 1000mAh

LED is LUX V Green (sorry forgot to mention this in the initial post)

10-23-2007, 01:48 PM
That explains it, in my opinion.

Your batteries are just able to provide enough voltage for the LED to light (Lux V = 6.9 fwd v) initially. Then, as a short time goes by, the voltage will wane a bit and drop to a more "normal" reading such as 7.2 or 7.4.

When the voltage begins to drop too low, the board will basically sacrifice "run time" to maintain the voltage so that the LED stays on. Remember also--the board is drawing current, the sound is as well (and any other possible "pretty" LEDs such as battery low ind. or the sequencer ones)...

...so 30 minutes of run-time sounds about right. Even with a full charge. 900mah is a paltry amount for something like a Lux V.

The batteries that would best serve you--would likely be the 18650 series cells. With 2400mah or more. You should get at LEAST one hour with a 7.2/7.4 setup of those, probably more though.

This is one reason why I did NOT choose to go with a Lux V green for one of my Flange III sabers. I went with a K2 green instead--because of the lower fwd voltage.

Darth Morbius
10-23-2007, 02:23 PM
My issue with the 18650's is that they wont fit my space requirements for the hilt I am using unfortunately.

I can use 14650's, but that is pushing the limits in rgard to space.

However, I just tried a 6AA setup, with the board out of the saber, and it is not even firing now at all either.

I have contacted Erv about it though, and I may see if Xwing might be kind enough to take a look at it.

Thanks for the tips though on the current issue, I appreciate it Novastar! :)

10-23-2007, 10:43 PM
You're welcome for the help...

6AA wired as 9v, I assume?

Darth Morbius
10-25-2007, 12:11 PM
Indeed 9v. :)

Erv has contacted me about it, and it seems that it my have something to do with the magnetic fields caused by the fridge magnet, and the speaker magnet, when in transit, or an X-ray issue from customs.

I'm just awaiting his email reply for the go-ahead to ship it back to him for repair. 8)

I hate to have to do it, since this will be the second board he has fixed for me (the first one wasn't my doing, and I hear it nealry gave him baldness and ulcers..)

10-26-2007, 09:48 PM
Hi there,
yes, I've been trying to collect info of different client to see if that has to see with the shipping. My guess is that is has nothing to do with that (I thought that the fridge magnet I generally offer with the board but I don't think it's the case, especially if the board continues to work, sometimes (means that it's not really wrecked).
My believe is that the card is not rebooting after power off. To restart properly, you need a frank power on, and the card must go to 0V first. Normally, a good recharge port + contact will do the job. However, if you have an isolation problem in the saber, like the luxeon backplate not isolated with cooltape from the hilt (the isolation problem happend to me several times, not only on the red lux family).
Because of that, the recharge port is bypassed and even when you put the kill plug, voltage is not totally cut. Measure the voltage a the input pads of the board to be sure.
Second point : current flowing thru the recharge port might cabonize the contact on certain plugs. You get the contact for the use of the saber, then you power it off, kill switch in, but when you remove it, the contact isn't there. I use some 3-in-1 oil to get rid of that, it has some good electrical properties.
Let us know how it goes

Darth Morbius
10-26-2007, 11:14 PM
The recharge port is fucntioning as it is supposed to, I checked that with the meter seperately from the board by building a ciruit to run just a Lux V with a 700mA buckpuck, and it's definitely cutting the power to 0V when used as a killswitch with the key plug.

I'll run some checks on what you recommended, and give it a whirl later tomorrow to see what result I get.

I'm realy hoping that it will work! :D

**Edit- No dice gentlemen; same results as before! However, I did notice that if I moved the negative wire for the Aux button to the GND pad instead of the negative loop to the battery, I got a short beep like it wanted to fire.

So I tried a reformat. Got the beep again but no dice on anything after that. I am at a complete loss.

10-28-2007, 01:54 AM
I wish I could self "beam me up" to the US to fix this, but here we are again : I'll handle that at the lab, I'm afraid you need to send this one back to me :oops: :cry:

Darth Morbius
10-28-2007, 11:46 AM
Sorry Erv, I've tried just about everything I can think of to get this board breathing, but it's flatlining on me.

I really really did try though! :oops: :cry: :?

10-29-2007, 12:33 PM
Don't worry Morbius--sometimes this kind of thing is unavoidable... it could be ANYthing... maybe even a TINY TINY solder "blip" laying on some component, or... just a mal-soldered pin on the initial creation of the board...

I'm very glad that everyone who usually wires up a Plecter has some "goes at it" first though! You really did do a lot of troubleshooting to exhaust any "normal" possibilities. :)

10-29-2007, 04:03 PM
I'm just impressed that there are so few posts like this one... it shows that Erv' is doing quality work. Especially when there are so many opportunities for the end user to botch things, we still rarely hear about problems with Erv's boards that aren't simply due to screwing up parameters, not reformatting the SD, etc.

I call for a world holiday: Plecter Day! (Maybe around Christmas to boost sales.) Heheh.

Argh...still waiting on the mail for my board...can't wait to get it, but now I decided to make a totally different hilt for it. My original one (a Heiland) wasn't worthy! Maybe a hasbro for that one...

Later y'all!

10-29-2007, 11:32 PM
Agreed, Sky! Not to mention, Erv pretty much "hand-solders" his boards... they are not made by some machine.

Although, if you want to get detailed and specific, obviously the PCB copper traces and print is INDEED done ahead of time... but as far as *I* know, almost 100% of the components are soldered on by Erv. He also tests every board before it heads out the door, so... you can be sure a board is working before it leaves France!

Problem is... things can be so delicate--ya never know.

10-30-2007, 02:22 AM
yeah... I'd love that the LAND well, still working. I anyway have from times to times little problems. The worst thing is static electricity that erase the code of the core. Happened twice (really really bad soldering iron).
But Novastar is right, All the boards are hand soldered and tested at least 15 minutes with a luxeon and speakers at full rate (1.5A).

10-30-2007, 03:08 PM
The worst thing is static electricity that erase the code of the core. Happened twice (really really bad soldering iron).

I've been wondering about ESDS (Electro Static Discharge Sensitive) parts in some of the sound boards. Not just CF, but Ultra's, Hasbro, and MR as well. I haven't read anything definitive about any dangers of ESD with them, except for the flat green resistor near the LED pads on the CF.

Is this something that needs to be addressed? Or is it really not a big problem with any of these boards? I was thinking maybe there should be a thread on it somewhere, but I dunno. Some people may not know that just handling some electronics can fry them, and after hearing of some problems with the Ultraboards, it kinda makes me wonder.

10-30-2007, 04:40 PM
Anything with a chip is going to be vulnerable to some extent or another, it's always a good idea, even with really durable circuits, to have a ground strap or something nearby that you can ground yourself on periodically (my place has exposed plumbing which works)

10-31-2007, 12:54 AM
Personally, I have been having a SMALL bit of "trouble" with the board "crashing", where:

1. Sound stops.
2. Light stays "maintained" at whatever current it was fluctuating at when crash occurred.
3. Power off switch becomes useless.

This may be because I (recently) somehow broke one of the leads that goes to the vibration motor and have not yet fixed it. Either that or the motor died... I'm still unsure of which.

I'm not worried about it. We'll see what happens over time. Much much MUCH experimentation must occur before isolating any "problem". It is probably that open/broken lead!!

10-31-2007, 01:49 AM
yep, goods points here. I ship all my boards with anti ES mylar plastic bags, but then when the board is manipulated, everything can happen. When soldering, also. Some irons are really badly isolated. The good thing, just like when you change a PCI card in a computer, is to touch the ground, plumbing, heater or whatever to discharge yourself.
Then, it also depends on the floor you have. And the shoes.
Also, it depends on the human being. Have you ever heard about those "cursed" people that cannot use a quartz / electronic wrist watch ? mainly because the accumulate a lot of electricity, all the time, and they got discharged on any electronic devices around.

Darth Morbius
11-08-2007, 02:23 AM
I actually know one of the cursed people like that Erv. My Grandfather.

He couldn't wear digital watches at all (Or any watch that utilized quartz). Wind-ups ONLY for him!

Anyhow, I am hoping it wasn't something that I did to mine.

I always use a ground strap when working with PCB's and all of my assembly is done on an anti static mat.

However, If it was something that can be caused by user error. I will gladly pay any fees needed for the repairs. :)

I know I was following schematics, because I read the users manual AND quick reference guides numerous times before even RECEIVING the board in the mail, and several AFTER receiving it.

11-08-2007, 04:11 AM
email sent DM :)

Darth Morbius
11-08-2007, 02:13 PM
email sent DM :)

*Bows to his master*

THANK YOU ERV!!!! :mrgreen:

Oh thank you thank you thank you!!!!!!!

Tom Starkiller
11-08-2007, 02:39 PM
I actually know one of the cursed people like that Erv. My Grandfather.

He couldn't wear digital watches at all (Or any watch that utilized quartz). Wind-ups ONLY for him!

My mum is like that :shock: