View Full Version : Crystal Focus 9 Constant Clash and Swing on Startup

01-14-2020, 05:07 AM
I posted this first in the troubleshooting thread, but got no responses there. This seems to be similar to what Goshivan is experiencing on this thread: http://forums.thecustomsabershop.com/showthread.php?23151-My-Saber-is-POSSESED!!

Built a saber in late December using a Crystal Focus 9 board with a b/b/w tri-cree. Shortly after getting it put together and running the SD card died.
This happens occasionally with SD cards so I figured I got a bad one, and replaced it with a new one that was reformatted and set up with the stock config from the Plecter Labs site.
It started exhibiting behavior where when we activate the saber it immediately starts making constant swing and clash sounds.
I thought that it was feedback from the speaker so I tried adjusting the sensitivity, but this had no effect.

After messing around with it for a while my kid pointed out that it worked normally when we switch sound fonts during the same session.

The battery is fully charged and the board is clean. The config is currently stock, but I have tried tweaking the motion sensing parameters which seems to have little effect on the problem unless I max out the parameters.
I've verified there are no shorts and have re-soldered my connections once to make sure I didn't mess anything up. Don't see any obvious signs of damage to components, but the area around the motion sensor seems to be a little hot when running. Not sure if this is normal or not.
Don't have a R.I.C.E. connector, so can't do real-time checking.
This happens whether the board is in the saber or when it's pulled and laid out on the bench. I've also checked it with various combinations of sound, main led and FOC LED's disconnected.

Does this sound like a board problem, and if so is there a repair option?
Any help would be appreciated.

01-17-2020, 10:04 AM
On a separate forum Erv suggested that I try a different battery or recharge port.
In his words:
I'm guessing a bad port or weak battery that brings a lot of ripple during the boot. With the vocal menu selection of the font, the whole thing has more time to stabilize
the reboot (aux switch) gives the proper time for the power supply to be applied. I suspect your recharge port is "weak" or "noisy"

This tracks as the current recharge port has occasional problems with charging and doesn't always make a good connection.
I'm putting in another order soon for a different project that will include a battery, and I'll throw in a couple of extra recharge ports and a R.I.C.E. setup to help with debugging.
Hopefully, this will clear up the issue.