View Full Version : CF7.5 may have failed

02-23-2016, 08:06 PM
Well, my first build with a CF7.5, got it buttoned up and worked fine. Then I decided I wanted to make some changes. I had a rumble motor hooked up to the pad next to the main led and didn't like it coming on only with that color. Decided to hook it up on another channel since I was using a Tri Rebel with a CEX. Forgot that #4 had no power extender and hooked up there by mistake. When I turned it on I realized my screwup but was checking things and noticed that my red main led was lighting when one of the accent leds was supposed to. This happened during sound bank selection only. I thought there might be a short between the wire to accent pad #6 and channel #3, as they are close together. So I resoldered all of my accent leds and switched the rumble motor to channel #3 and the red main led to channel #4. Since then, nothing but problems.Saber won't start properly. I desoldered the rumble motor and put the red led back on channel #3. I replaced the recharge port and checked my connections. I formatted and recopied the SD card files. All I got was a boot sound and no activation or aux button response. Today I took everything off the board and cleaned all the pads with desoldering braid. I hooked up only the switches, recharge port, battery, speaker and main led. Still only get a boot sound and no switch function. Don't know if the board has failed or just me. Any ideas?

02-23-2016, 10:51 PM
Charge your battery?

02-23-2016, 11:25 PM
Oh yeah, over 8v. The problem seems to be in the board. Rice reads the SD card when I remove the kill key and get the boot sound, according to Max Window, but doesn't communicate with the board after that. Tomorrow I'll try debug in the sound font and see what it says.

02-24-2016, 07:57 PM
I ran debug from the first line of the sound font and the file list looked OK accept for one line that read, "number bad arguments for message "set". This was just above, Sleep Timeout=50000. Double clicking on the error message takes me to the Sleep Timeout number field. Tried changing it to 5000 and copying to re-formated SD and get the same error message.

02-24-2016, 09:41 PM
Checking the voltage around the board, I found full voltage (8.0v) at the Accent Pads. And the MCU is getting pretty warm. Does not seem like regulated voltage anymore. Depressing to think I'm out a $150 board after one week!

Silver Serpent
02-25-2016, 09:39 AM
Contact Zook. He's the official repair guy for Plecter boards in the US. You're not out a $150 board, he should be able to fix it for a small fee.

02-25-2016, 09:55 AM
Thanks SS. Tim replied to a message and gave me contact info for TCSS repair. Hope it's not beyond that.

02-25-2016, 07:50 PM
Emailed back and forth with one of the CF builders and couldn't pin it down, so I shipped the board off to him for repair. I feel one thousand percent better that a pro will take a look at it. He had some ideas that might relate to a problem they used to have with an older chip. We will see.

02-26-2016, 10:32 AM
I will use the time to make some changes to the hilt design. Now that I know how much room I actually have for the electronics, I will shorten the length of the saber at the pommel. It will still allow a two handed grip but won't seem a mile long. I might rethink my grip, as well. I had done a tsuka ito wrap but it was a little bulky and made spinning a bit difficult.

02-27-2016, 09:35 PM
Zook is the best, he repaired my CF earlier this year, very cheap and it works fantastically!
You're in good hands.