View Full Version : PC3.5 Boot sound, no activation

05-27-2015, 08:27 PM
So, I should start off by saying that I've had my entire setup wired together and it's all worked fine before -- I started rewiring it this time to set wire lengths to what they need to be for when it all goes in to my hilt. But I've got this issue, where I get a boot sound when I pull the kill key, but the card won't activate. I've tested both the switches and they're fine, I've checked the config files on the SD card and the switch setting is set to momentary (switch=2). I have no idea what the problem is here. Maybe I touched the board in the wrong spot? I don't see anything that looks blown or like it shorted out. Help me Obi-Wan Kenobi!

Album of wiring and board (http://imgur.com/a/sl1Py)

05-28-2015, 06:11 AM
How did you check the switches? One of their legs go to the GND, other to the Switch pad of the board. Anyway, even if you configure it false, it should Show a reaction anyway when you push it too Long/not at all/shortly (depending on what the board is told the Switch Looks like).
The boot Sound AFAIK also Comes from the SD-Card, so I guess if the SD-Card is corrupted/wrong, the boot Sound would also not Play. Does it Play in Loop or only once?
But it's really strange that None of the Switches react. You could have accidentally tore one of the wires, but not multiple ones...
What if you take a Piece of wire and short GND to one of the Switch pads?

05-28-2015, 06:20 AM
I checked them briefly with my multimeter -- I'll check them again tonight to be sure. That was my thought on the boot sound too, and I checked the SD card in my computer; Windows, at least, thinks it's fine. The boot sound just plays once, so the board seems to be booting correctly as far as I can tell. I haven't tried shorting the connections -- I'll try that tonight too.

05-28-2015, 09:07 AM
I checked the switches again and they're both fine. I tried shorting the act->gnd connection and nothing happened.

Forgetful Jedi Knight
05-28-2015, 09:21 AM
Have you checked the override config file and did you make sure the switch setting is correct in that file as well?

05-28-2015, 10:02 AM
I tried the same SD card in a second PC (that does work fine) and everything worked as expected. I'm 98% sure at this point it's the PC itself. I just don't know if it can be fixed or if I have to replace it :(

Jay-gon Jinn
05-28-2015, 12:38 PM
Contact forum member Zook, he is the authorized soundboard repair specialist in the U.S.

05-28-2015, 01:32 PM
Thanks Jay-gon, I just sent him a message on the FX forums asking about it! Hopefully it isn't perma-broke haha

05-29-2015, 04:27 PM
Have you seen a tiny bubble on any of the parts on the board. I ran into this same problem, Just boot sound, and nothing else. I found a small bubble on the CPU, telling me it was fried, or something in it was, so I had to send it out for repairs.

05-30-2015, 01:09 PM
I gave the issue a secound thought today and ran down into the Basement to try one of my PC sabers.

I wanted to recreate the same you describe on a working saber. This is what I've found:
1. If I pull out the kill key while pressing the activation Switch, the same will happen as in your case: boot Sound will Play but nothing else will work. This simulates a case the activation Switch terminals are shorted or the non-GND terminal is shorted somewhere else to GND (at the end of the day this Switch is always on).
2. If I do the same with the aux. Switch, after the boot Sound it will start browsing the Sound Fonts. So I conclude your aux. Switch is all right.
3. Lastly I tried my CF-LS saber which has a latching Switch. If I pull the kill key while the Switch is on (it's a normally open one), the boot Sound will Play then the saber will immediately ignite.

What I want to say with all These: it's worth a try to check if your activation Switch is shorted. I know you mentioned you checked the Connections, but maybe not with a short in mind. Alternatively, if you do not have an easy Access to the landings/solderings/multimeter, you can try to define your main Switch as a latching (normally open). I guess a CF and a PC in this sense are identical, so if you indeed have a shorted act. Switch, doing this will have it ignited.

I Keep the fingers crossed that this was the only matter.

05-31-2015, 06:17 PM
I should have posted back here sooner with what Zook/MH/Chewbacca (fx forums) and I concluded. After I described the situation and detailed what experiments I had and hadn't done, we ran through a couple things before concluding the following: that I had been working on the board with the positive power terminal still connected from the charge port. The issue, and a potential fix (which works about half the time) are detailed here (http://www.fx-sabers.com/forum/index.php?topic=26167.msg435224#msg435224) by Erv. Unfortunately, I tried the fix and had no luck, so I'll be sending my board off to Zook to be repaired.

EDIT: I should add that working on the board with the positive power terminal still connected, as Erv says on that post, fries the switch input in the processor. The lesson learned here is that no matter what work you're doing, ALWAYS disconnect the power completely before you start soldering anything.

Forgetful Jedi Knight
05-31-2015, 06:41 PM
Yeah, that would be an issue.