View Full Version : PC3.5 wiring with MHS wiring parts

12-08-2014, 05:58 PM
Forgive my ignorance, as I've been trying to figure this out all night.

I have a PC3.5 (just got it today) that I am trying to wire up. I'm staring at wiring diagrams, and I thought it was all wired up good. I go to fire up the saber and nothing happens.

I'm using the MWS wired recharge port and MWS wired momentary switch.

I have the switch wired to the ground and activation pads and the LED ring ran to the accent LED

My recharge port is connected to the power pads and to the battery pack

LED is connected to the LED pads.

Any suggestions?

Forgetful Jedi Knight
12-08-2014, 06:21 PM

12-08-2014, 06:42 PM
I'll post some in a minute. I was getting a fast flashing LED ring for a couple seconds. Now it's just dead. I wired the LED to the AUX switch pad to see if it made a difference. I got the same result.

12-08-2014, 06:50 PM
106351063610637Here are the pics.

Forgetful Jedi Knight
12-08-2014, 07:02 PM
Well, I have no idea what you could be connecting the switch LED to. Also a picture with everything connected (or connections scotch taped together for a pic) would be nice.

I also don't see an Aux switch anywhere.

12-08-2014, 07:11 PM

Forgetful Jedi Knight
12-08-2014, 07:15 PM
The yellow JST shouldn't be connected. The wires you have them connected to are meant for the Aux switch. Otherwise everything looks ok.

You may want to check the configuration files and make sure that the switch setting is set to "2", and check any override configuration files as well.

12-08-2014, 07:42 PM
Tried it without the yellow JST and nothing. Tried hard wiring everything by cutting off the JST connectors and connecting them together and there's nothing. I also checked it with a latching switch instead of a momentary and got nothing. I think I got a brick.
I checked all the settings on the SD card, too.

Forgetful Jedi Knight
12-08-2014, 07:48 PM
Did you charge the battery?

12-08-2014, 07:52 PM
Completely charged.

12-08-2014, 11:22 PM
In the last pic the red and black JST should not be connected where it is.. the yellow should be. The PC uses 2 switches generally.. make sure the yellow one is hooked to the main switch and not the aux.

The red/black are for the accent LED and should be connected to the accent pads which are currently not wired.

12-09-2014, 06:13 AM
I've tried both combinations just to see if something wasn't right.

My first wiring was: Yellow positive went to ACT and Yellow Ground went to GND next to the AUX positive pad. Red with resistor went to accent 1 and black went to GND. This is when I got a fast flashing red for about 3 seconds and then nothing.

Then I used the shared pad connector that I bought and wired the yellow positive to ACT and yellow negative to GND with the shared positive cable to the AUX. Same results: fast flashing red for 3 seconds on the switch and then nothing.

After reading FJK's post about not needing the yellow JST I switched it to red and black. No light on the switch, and board didn't work.

Then I cut off all my JST connectors to hardwire it. Yellow positive and negative to ACT and GND. Red and black to Accent 1 and accent GND. Hard wired the battery pack to the board completely skipping the recharge port. Absolutely no life to the switch or the board.

12-09-2014, 06:18 AM
After all that, I decided to try a latching switch in case my SD file wasn't right. (At this point all I did was verify the information was right.)

No life from the board. Every video I watch shows them connect the speaker and the power with the LED just to test it and it fires right up. I tried it and that didn't happen.

12-09-2014, 09:31 AM
Please take a picture with it wired up correctly. Just do battery,LED,speaker,switch (no switch LED).. also a picture of the solder points would be helpful as well.

12-09-2014, 03:25 PM
I see a few things.

Do you have pics of the bottom? I am concerned because you have the wires sticking through the holes. It is generally not acceptable to do it that way. Your wires may be touching on the bottom (or not but its something to look at).

Next I want you to take everything off including the switches. Clean the pads if you have solder wick.

Directly wire the battery to the board bypassing the recharge port and all JST connections. Then hook up the speaker directly to the board and the LED directly to the board. See if it boots up after you stick the batteries in after doing that. Then try to turn the board on using tweezers on the switch pads.

Lastly...have you been soldering with the SD card installed in the board? You need to make sure you take the card out when you solder to the board or it can damage the it.

Can you read the SD card from a PC?

12-09-2014, 08:32 PM
Did all that. No boot sound at all. SD card reads. Didn't solder with the card in.

12-09-2014, 10:09 PM
So here is where I'm at with the card:

SD card was not in while soldering. I plugged it into the computer and made sure it wasn't blank. Upon checking it a second time, I decided to run a scan on the SD. I was greeted with bad sector errors that needed to be fixed. I fixed those and rechecked the SD card. The SD card is good to go.

The PC3.5 was originally wired with JST connections for the battery, LED, recharge port, and switch and LED. Original wiring had the wires going through the holes and soldered. All connections were solid and we're not bridged. The Yellow JST of the switch was wired to ACT and GND. The LED ring was wired to Accent 1 and GND. Upon applying power I did not have a boot sound and had a flashing red LED on my switch that lasted 3 seconds and then completely stopped. Main LED tri rebel did not fire up. The tri rebel was tested already, and I posted about how bright it is.

Moved the LED ring connections for the switch to AUX. same results.

Followed FJK's advise. Nothing. No boot sound, and now the LED is not flashing.

I cut off all the JST connections and soldered the wires direct. No flashing lights, no LED, no boot sound, no lighting of the tri rebel.

I de soldered everything and cleaned it up with braid. Resoldered everything to the top of the board without the wires going through the holes and checked all connections. Same results: no boot sound, no LED, nothing.

Followed Tim's instructions with the same outcome. No sound or lights. I even had Tim on the phone.

Redid all the connections with just the battery, Tri rebel, and speaker. Nothing.

12-09-2014, 10:12 PM
Oh and I forgot to mention that the card now has heat marks from constantly soldering and desoldering now. If some of the cards on YouTube are any indication (burn marks and booger globs of solder and the card still works) I should be fine.