PDA

View Full Version : PC 2.0 acting strange



Xene
12-17-2012, 04:23 AM
So I wired up my bored (after lots of questioning) and did a test fire up tonight while it wanst in the saber and a really strange thing happened, the main LED and illuminated switches worked great, but the saber appeared silent, upon deactivation, i heard the faintest sound, so I rebooted it and sure enough if I listen carefull I can make out the activation blaster bolts and deactivation, im guessing the hum and boot sounds are too quiet for me to hear. I went and checked the SD card and the volume was at max~has anyone else had a simular problem? for the record I did do a bit of searching on this subject but couldnt find anything~please help?!

shmoetech
12-17-2012, 05:19 AM
try switching the lead for your speaker around.

Darth Xusia
12-17-2012, 08:05 AM
Speaker polarity doesn't matter. Do you have another speaker to try?

jin starkiller
12-17-2012, 09:52 AM
speaker might be the problem or do you have a fresh charge on the batteries

BlessedWrath
12-17-2012, 12:39 PM
Here's hoping it's the speaker, but...did you through-hole solder the speaker leads? I remember some PC-using members having had trouble with the speaker leads shorting against the SD card holder. It could also be ESD damage to the board. ESD is unpredictable; it's not hard to believe that a static shock could burn out just the audio driver. You could also check your speaker connections. A loose or poorly formed connection could be the cause.

One last thing to check is something that I ran into on my first saber: Check that the speaker-side connections aren't touching the speaker housing. It's difficult for me to explain without pictures, but if the wires are soldered flat against the speaker terminals, a little bit of extra wire sometimes hangs over. If this extra wire contacts the speaker's metal body, it can short. Fortunately this problem didn't fry any components, but it did cause the speaker to cut out.

Xevious
12-17-2012, 12:55 PM
It could also be ESD damage to the board. ESD is unpredictable; it's not hard to believe that a static shock could burn out just the audio driver.
Possible, but not probable. ESD damage is more of a danger at the component level. Complete PCBs are more likely to be damaged by improper connections, over-voltages, etc.

Certainly check the speaker solder points as they are very easy to short-out on the body. You can (if you disconnect the existing speaker), try out another speaker with some alligator clips (e.g.: computer speakers). It should be plenty loud without any further amplification.

Xene
12-17-2012, 03:50 PM
@Darth Xusia-that was the first thing I tried, no difference
@BlessedWrath-it origionally was (no the solder didnt touch the SD holder) but due to someone nudgeing me while I was soldering somthing else it came out and I had to resolder it flat against the board, still not touching the SD holder ;) and Ill have to check that bit about the speaker housing~though getting it out of the holder is gonna be fun~really wedged in there, which could be the reason that the wires touching the housing could be the problem~
@Xevious-I do have another speaker~Ill go and try it now~

Its so weird that it hasnt stopped working though, its just really quiet, which makes me think it could just be the speaker cause a short would cause the speaker to not make sound right?

jedimastergarcia87
12-17-2012, 04:14 PM
Any luck fixing your board?

Xene
12-17-2012, 04:21 PM
not yet the speaker i was going to test with is broken, ill have to find another~

BlessedWrath
12-17-2012, 04:38 PM
Try wiring an audio patch cable to the speaker pads. A standard audio jack can be plugged into computer speakers, your laptop...anything that has an audio-in port. That should confirm whether it's been the speaker or not.

I did something similar when my original speaker broke. I needed to confirm that everything worked right, so I used a set of portable speakers instead.

Xene
12-17-2012, 04:55 PM
you mean like headphone cable?(not too sure what an auido patch cable is ^//^)

and i did find another speaker, a little 8ohm 0.5 watt one from a metronome i have, stangely i think it may have been a little louder 0.o and aol the wireing from the TCSS speaker im using was ok, none was touching the speaker housing~