View Full Version : Problems with Main-LED on Petit Crouton

07-30-2012, 09:49 AM
Hey there!

One of my two petit crouton (v1.5) is making trouble. Board was working for over a year now.

When pushing the on/off button the led turns on very slowly.
When on the led lights up static instead of the normal flickering of the blade.
When clashing the led turns of sometimes for a little moment.
And when turning off the saber the led remains on.

Any ideas on how to fix that???

Silver Serpent
07-30-2012, 10:19 AM
First thing I'd do is check the batteries. If they're rechargeable, try recharging them back to full. If they're not rechargeable, try replacing them with fresh ones.

07-30-2012, 02:31 PM
I couldn't figure out why my saber speaker was so quiet. A change of batteries fixed it! Take silver serpent's advice; he's always right.

Silver Serpent
07-31-2012, 05:29 AM
There are exceptions, but they usually occur before I've had my coffee. ;)

07-31-2012, 11:32 AM
Sorry guys, but my speaker is ok!

There is only that problem with the led. I already thougt about the batteries and replaced them with non-rechargeable ones, but it didnt help.

Silver Serpent
07-31-2012, 11:40 AM
The speaker will usually run fine with less power than is needed to run the LEDs, so the sound can be fine with the LED acting up.

What type batteries were in the saber before? And what did you replace them with? If you went from 2 li-ion batteries to 2 alkalines, you'll have the same issue.

You *might* have a loose connection somewhere, but I'd rather rule out power issues before asking you to dismantle the saber.

07-31-2012, 02:06 PM
The thing is that saber has run fine for over a year...

The problems occured while trooping. At that moment i used some nimh-rechargeable batteries. When i was at home i had the same problems like above. So i changed from the nimh-batteries to normal alkalines. But the problem remained. So i checked the soldering connections but could not find any damages. So i think that either the cpu of the board or some kind of transistor that drives the led might be damaged.

When i let run the led after switching of, you can even feel that the saber is getting hot at the blade holder... So that might be some kind of transistor, but im not sure which one drives the led and which type it is to be replaced...

Jay-gon Jinn
07-31-2012, 04:18 PM
Do you happen to have another led you could try? It sounds to me like you have a short in the main blade led, or its blown.

Kevin Starwaster
08-01-2012, 11:37 AM
Aside from the led not shutting off, those symptoms are all things that can be configured. Activation speed, flicker and FoC. Did anything change there?

08-04-2012, 04:39 AM
Ok guys.

Some minutes ago i put a new led to the saber and the problems remained.

So i took the sd card from my good saber and put it in the defect one but the problems still remain.

Any new helpful suggestions???

09-06-2012, 04:27 AM
Problem solved!

One of the electical components on the pcb wasnt soldered correctly. So after some extensive fighting it got loose. I resoldered that component and now the saber works perfect again!

09-06-2012, 05:21 AM
Glad you were able to resolve your issue!