View Full Version : Petit Crouton - no main LED power

10-21-2011, 09:50 PM
Hey all - just got the last of my parts in to build my first saber. Started wiring the Petit Crouton board tonight...so far as I can tell from the manual, everything seems to be wired correctly... i've got my 2 li-ion 14500 trustfires, speaker, switch, and luxeon rebel star soldered into the appropriate pads. When I power it on, the appropriate sounds are working (as well as swing/clash sounds, etc)...all seems to be functioning except for the important part...the LED. I threw a voltmeter up to the pads and it read a big zero. After pulling a few hairs out i snipped the wires and ran the LED straight to an old 4xaaa battery pack (with appropriate resistor) and verified that the LED does indeed work when powered directly.

Is there anything obvious that I'm forgetting perhaps? getting desperate at this point...hoping I didn't throw $125 down the drain :(

The only thing I've been able to notice is that the positive LED pad is pretty tight next to a connector for a different component on the board - not sure what it is...in the manual on the site it shows up as a round component on the far right edge in the middle, just above the positive LED pad... on my board it happens to be more squarish. At any rate i'm not sure what that component does, and unfortunately i didn't get a good enough look at that area before i began soldering to see the "before"...right now though it looks like there might be a connection or some solder that's bridging what small gap there might have been between that component and the positive LED pad. I tried cleaning out as much solder as I could and it still looks too tight for me to tell if there's a bridge there or not. So i guess my questions would be: what's that component above that positive LED pad for, and should it be connected in any way/shape/form to that positive pad? again the area between them is so small that i can't really tell if it even is connected or not...i'm just grasping at straws right now trying to figure this out :(

The yellow ring outlines where I'm talking about on the card:


Unfortunately that pic isn't a high enough resolution for me to zoom in and see if there's supposed to be a connection in there between those 2 components.

Thanks for any help/suggestions!

10-22-2011, 02:53 AM
It should be bridged to the pad.

Wong Yoon Wei
10-22-2011, 03:14 AM
Not trying to sound obvious but did you reverse the polarity?

10-22-2011, 07:06 AM
to be honest... THAT HAPPEBNED TO ME!!!! ask PR lol he helped me lol. get desoldering braid and start cleaning that area. My situation ended up ok.

10-22-2011, 10:24 AM
Not trying to sound obvious but did you reverse the polarity?

haha there is no obvious for me :) i know some bits here and there when it comes to electronics but i'm far from what i'd call knowledgeable. Are you asking if i just wired the LED backwards? if that's what you meant then i did double check all that. if you meant something else then i might need a bit of direction as far as what to check.

thanks again!!

10-22-2011, 01:26 PM
well i went through with the vacuum sucker and the braid and cleaned up all the solder in that area and redid each of the connections...same story :/ sounds all work when it powers on, but nadda out of that main LED. Pretty positive I hooked the wires to the correct pads (pretty easy with this one...a clear + and - next to each one heh)- just to make sure though I even tried swapping them but of course no difference. afterwards, i hooked the LED up directly to a power source and sure enough it's still working fine. It just doesnt seem like the board is pumping out and juice to that main LED pad (not sure what i should be reading, if anything, when putting a voltmeter on those pads while the switch is closed and the led should be on...but currently i'm reading 0 still)...is it possible i got a dud? Or is there anything else on the board i should check that could impact this?

10-22-2011, 02:33 PM
here's a pic of the board...and i know i know my soldering is a bit rusty...not the cleanest but everything else works and i haven't seen any obvious shorts, except from the main LED positive pad to the component above it, which someone replied earlier was supposed to be bridged. Anyways if anyone is able to see any obvious issues or failures on my part, i'd welcome the criticism :) at this point i just want the lightsaber to have...light...haha.


Top left pair = batteries, mid left pair = speaker, top center 3 = switches, bottom right = main LED

10-22-2011, 02:53 PM
If it's not bridged somewhere top or bottom (can't tell from that pic). PM Zook here and he can repair it.

10-22-2011, 03:04 PM
i think you have the same issue as me. next to the square piece is the LED pads, did and solder get on its holder? thats what happened to me.

10-22-2011, 03:05 PM
hmm i might be too new to these parts or something...not looking like i've been given messaging permissions yet :/ ah yes looking now im about 14 days short according to the faq - d'oh :)

10-22-2011, 03:09 PM
i think you have the same issue as me. next to the square piece is the LED pads, did and solder get on its holder? thats what happened to me.

when I first attached the LED wires, i thought some solder did get over onto that square piece...when i finished i wasn't sure if it was a mistake on my part or if it was already soldered to that area, which led me to ask if it wouldve already been connected 'out of the box' before i had touched it. were you able to fix your issue?

Wong Yoon Wei
10-23-2011, 12:53 AM
Not to sound obvious again but are your batteries charged? Sometimes, the battery might have too low of an output to power the LED but enough to power the sound.

10-23-2011, 03:15 AM
yep i worried about that too...made sure they had plenty of time on the charger beforehand. still nadda :/ thanks for the idea though!

Jacen Solo
10-23-2011, 06:53 AM
Some other obvious questions but what is the led value in the config file set to? Is the config file properly set up on the sd card?

10-23-2011, 06:42 PM
I tried adjusting the LED value a couple of times...from 35 to 46 and back, no change. As for the rest of the config file, i haven't changed any of the other values since I unwrapped it...looking at them and comparing them to the manual, they all appear to be appropriate settings.

Lord Dottore Matto
10-24-2011, 09:29 PM
Sounds like you bridged the LED driver to the (+) LED solder pad. Easiest way to figure it out would be to have Zook look at it.

10-26-2011, 05:41 AM
I ended up sending it out for repairs this morning...hopefully whatever I did wasn't too bad to fix :/ Thanks all for the help!

11-12-2011, 01:27 AM
If Zook = Michael then you have nothing to worry about he's a PRO, and it doesn't sound too bad probably just a short somewhere he will be able to find under a scope or by backlighting the board... Take a deep breath you'll be fine.